Quest items not visible or obtainable/White quest items

  • Im having a problem completing some quests, mainly because I CAN'T see or pick up the items I need to complete them, i've dropped and regained the quests but I still can't see the quest items. This issue has persisted since the patch a few days ago. Also some of my quest items in my inventory are now white boxes. The names remain, but the icons are just white boxes. I've tried this with 3 quests, (Hans Request 1 (Repeatable), Spirit with Lost Heart, and strength enhancing elixir) the Slyph Feathers, Slyph Tears, and Blue Trumpy Eyelashes are dropping confirmed by random people whom I have killed mobs in front of, but I cannot see them or pick them up, i've gone to the exact spots where they see the items and tried to use the "Pick up item" ability, but still can't obtain them. Anyone know how to fix this?

  • I feel like its something related to some icon file you're missing (Ressmenu > Icon), reason for which when you get the item in your inventory you actually can see the description, but without the right icon assigned to the item, the game automatically display that as a "white" box.


    I'll either try to have a friend to send me the Icon folder and replace it (this needs to be done when the game is closed) or else just run the repair tool and re-download the latest patch(es)